SOMME de RECHERCHEV

Fonctions utilisées :
SOMME de RECHERCHEV sur Excel

Résumé

En fonction de votre situation vous pouvez vouloir :

  • Faire la SOMME de RECHERCHEV appliquées sur plusieurs colonnes ;
  • Obtenir toutes les valeurs relatives à une valeur cherchée et en faire la somme.

La formule ci-dessous additionne les résultats des fonctions RECHERCHEV effectuées sur plusieurs colonnes. On a utilisé un argument matriciel.

= SOMME( RECHERCHEV( "bureau 1" ; B2:D7 ; {2;3} ; FAUX ) )

La formule suivante additionne toutes les valeurs en fonction d’un critère donné. On se sert ici de la fonction SOMME.SI.

= SOMME.SI( B3:B7 ; "chaise" ; C3:C7 )

Formule Excel – SOMME de RECHERCHEV

SOMME de RECHERCHEV appliquées sur plusieurs colonnes
= SOMME( 
    RECHERCHEV( 
      valeur_cherchée ; 
      matrice_recherche ; 
      {colonnes} ; 
      valeur_proche ) ) 

Somme des valeurs relatives à une valeur cherchée
= SOMME.SI( plage ; critère ; somme_plage )

Explications

Suivant votre objectif, vous pouvez vouloir faire la somme de plusieurs RECHERCHEV effectuées sur un même tableau et récupérant les valeurs dans plusieurs colonnes ou vous pouvez souhaiter récupérer toutes les valeurs relatives à une valeur cherchée et en faire la somme.

Pour cela, la solution et la formule Excel à utiliser ne seront pas les mêmes.

SOMME de RECHERCHEV appliquées sur plusieurs colonnes

La fonction RECHERCHEV permet de rechercher verticalement une valeur et de renvoyer une des valeurs située dans les cellules à sa droite. Dans la formule suivante, la RECHERCHEV vient identifier la position de la valeur « bureau 1 » dans la plage de cellules B2:B7 et renvoie la valeur située sur la même ligne dans la seconde colonne de la matrice indiquée (ici C2:C7).

= RECHERCHEV( "bureau 1" ; B2:D7 ; 2 ; FAUX )

En utilisant un argument matriciel, on peut indiquer plusieurs colonnes à renvoyer. Le résultat sera indiqué sous forme de tableau composé d’une colonne et d’autant de lignes que nous souhaitons récupérer de résultats.

= RECHERCHEV( "bureau 1" ; B2:D7 ; {2;3} ; FAUX )

Grâce à la fonction SOMME, on peut additionner les valeurs renvoyées.

= SOMME( {150;163} )

= 313

SOMME des valeurs en fonction d’un critère

Pour faire la somme des valeurs en fonction d’un critère, la meilleure solution est d’utiliser la fonction SOMME.SI. Dans notre exemple, elle permet d’additionner les quantités dans le stock A pour l’article « chaise ».

= SOMME.SI( B3:B7 ; "chaise" ; C3:C7 )

Si vous souhaitez appliquer plusieurs critères, il faudra alors vous tourner vers la fonction SOMME.SI.ENS ou la fonction SOMMEPROD.

Formules en lien

4.7/5 - (19 votes)

Vous avez apprécié cet article ?

Pour me soutenir, cliquez sur cette publicité. Pas besoin d’acheter, un clic suffit.

Merci. 🤩

Annonces

Modèles Excel

+

Livret 

7 méthodes pour gagner 2H par semaine sur Excel

C’est gratuit 🤩

Les formations

Formations Excel

Parce que chacun devrait avoir les moyens de faire son travail sur Excel

Découvrez des formations accessibles, rapides et directement applicables.