SI ESTNA RECHERCHEV

Fonctions utilisées :
SI ESTNA RECHERCHEV Excel

Résumé

Pour masquer l’erreur #N/A avec la fonction RECHERCHEV, vous pouvez utiliser la fonction SI et la fonction ESTNA. Dans l’exemple ci-dessus, la formule en F5 est :

= SI( ESTNA( RECHERCHEV(E5;B5:C10;2;FAUX) ) ;

"non trouvé" ;
RECHERCHEV(E5;B5:C10;2;FAUX) )

Cette formule vérifie si la valeur « GH – 1824 » saisie dans la cellule E5 est présente dans la liste des articles et renvoie le prix le cas échéant. Si la valeur est absente, le texte « non trouvé » sera affiché.

La fonction SI.NON.DISP permet d’obtenir le même résultat avec une syntaxe plus courte.

Formule Excel – SI ESTNA RECHERCHEV

= SI( ESTNA( RECHERCHEV(...) ) ; valeur_si_na ; RECHERCHEV(...) )

Explications

Dans notre exemple, nous voulons vérifier si la fonction RECHERCHEV retourne une erreur. Si tel est le cas, nous voulons que soit renvoyée la valeur « non trouvé ». Pour cela, nous allons utiliser la fonction SI associée à la fonction ESTNA.

Si vous voulez contrer l’erreur #N/A, préférez la fonction SI.NON.DISP. Je limite l’utilisation à la combinaison SI et ESTNA dès lors que je veux renvoyer une autre valeur que le résultat de la fonction RECHERCHEV si la valeur est trouvée (ex: vérifier si une valeur est présente dans la liste).

Fonction RECHERCHEV

La fonction RECHERCHEV permet de rechercher verticalement une valeur et de renvoyer une des valeurs située dans les cellules à sa droite. Dans notre cas, nous souhaitons vérifier la présence de la valeur dans la plage de cellules et renvoyer le prix. Si l’article est absent, l’erreur #N/A sera renvoyée.

= RECHERCHEV( E5 ; B5:C10 ; 2 ; FAUX )

--> Résultat: #N/A

Fonction ESTNA

La fonction ESTNA vérifie si une formule ou une cellule renvoie une erreur du type #N/A. Si c’est le cas, elle renverra la valeur VRAI. Dans le cas contraire, elle renverra FAUX.

= ESTNA( RECHERCHEV(E5;B5:C10;2;FAUX) )

--> Résulat: VRAI

Fonction SI

La fonction SI permet de réaliser un test et d’afficher un résultat si le test se révèle VRAI et un autre résultat si le test se révèle FAUX. On peut renvoyer une valeur numérique, du texte ou une formule.

= SI( test ; valeur_si_vrai ; valeur_si_faux )

Dans notre cas, la formule composée de la fonction ESTNA et de la fonction RECHERCHEV sera placée en tant que test. Elle est acceptée en tant que tel car elle renvoie une valeur de type booléen (VRAI/FAUX).

Nous souhaitons que si la fonction RECHERCHEV renvoie une erreur, la valeur « non trouvé » soit renvoyée. Dans les autres cas, nous souhaitons avoir le résultat de la fonction RECHECHEV.

= SI( ESTNA( RECHERCHEV(E5;B5:C10;2;FAUX) ) ;    --> test

"non trouvé" ; --> valeur_si_vrai
RECHERCHEV(E5;B5:C10;2;FAUX) ) --> valeur_si_faux

Fonction SI.NON.DISP

La fonction SI.NON.DISP (disponible sur les versions récentes d’Excel) est une meilleure solution pour arriver au même résultat. Elle vérifie si la formule renvoie l’erreur #N/A et permet d’afficher une autre valeur (ex: renvoyer une valeur nulle). Sa syntaxe est :

= SI.NON.DISP( formule ; valeur_si_na )

Dans notre cas, il suffit de placer la fonction RECHERCHEV en tant que formule et de préciser que si la fonction renvoie #N/A on veut afficher « non trouvé ».

= SI.NON.DISP( RECHERCHEV(E5;B5:C10;2;FAUX) ; "non trouvé" )

Choisir entre SI+ESTNA ou SI.NON.DISP

Comme expliqué, lorsque je rencontre un cas comme celui présenté dans l’exemple (besoin de masquer/remplacer les #N/A) je choisis la solution SI.NON.DISP.

Il arrive parfois que je veuille simplement vérifier la présence d’un élément dans une colonne et renvoyé un résultat personnalisé s’il est présent ou absent. Je choisis alors la solution SI + ESTNA. Voici un exemple concret :

= SI( ESTNA( RECHERCHEV(E5;B5:C10;2;FAUX) ) ;    --> test

"non trouvé" ; --> valeur_si_vrai
"trouvé" ) --> valeur_si_faux

Cette formule vérifie si l’article est présent dans la matrice et renvoie « trouvé » si c’est le cas et « non trouvé » dans le cas contraire.

Formules en lien

5/5 - (5 votes)

Vous avez apprécié cet article ?

Pour me soutenir, cliquez sur cette publicité. Pas besoin d’acheter, un clic suffit.

Merci. 🤩

Annonces

Modèles Excel

+

Livret 

7 méthodes pour gagner 2H par semaine sur Excel

C’est gratuit 🤩

Les formations

Formations Excel

Parce que chacun devrait avoir les moyens de faire son travail sur Excel

Découvrez des formations accessibles, rapides et directement applicables.