Si RECHERCHEV est vrai alors

Fonctions utilisées :
Si RECHERCHEV est vrai alors

Résumé

Pour vérifier si un RECHERCHEV est vrai, vous pouvez utiliser une formule avec la fonction SI, la fonction NON, la fonction ESTNA et la fonction RECHERCHEV. Dans l’exemple ci-dessus, la formule en H4 est :

= SI( NON( ESTNA( RECHERCHEV(D3;$B$3:$B$10;1;FAUX) ) ) ; "oui" ; "non" )

Cette formule vérifie si la valeur OD5894 est présente dans la liste des codes articles (plage B3:B10) et si tel est le cas, elle renvoie « oui ». Dans le cas contraire, elle renvoie « non ».

Formule Excel – Si RECHERCHEV est vrai alors

= SI( NON( ESTNA( RECHERCHEV(valeur;plage_recherche;1;FAUX) ) ) ; "oui" ; "non" )

Explications

Dans notre exemple, nous avons une liste de codes d’articles ainsi que quelques codes sur lesquels nous devons vérifier la présence dans la liste initiale. Nous souhaitons pouvoir retourner un résultat personnalisé. Pour cela, nous allons utiliser la fonction SI, la fonction NON, la fonction ESTNA et la fonction RECHERCHEV.

Fonction RECHERCHEV

La fonction RECHERCHEV permet de rechercher verticalement une valeur et de renvoyer une des valeurs située dans les cellules à sa droite. Dans notre cas, nous souhaitons juste vérifier la présence de la valeur dans la plage de cellules. Nous renvoyons comme résultat la valeur cherchée. Si la valeur est trouvée, elle sera renvoyée. Dans le cas contraire, ce sera l’erreur #N/A qui sera renvoyée.

= RECHERCHEV(D3;$B$3:$B$10;1;FAUX)

--> Résultat: "OD5894"

= RECHERCHEV(D4;$B$3:$B$10;1;FAUX)
--> Résultat: #N/A

Fonction ESTNA + Fonction NON

La fonction ESTNA vérifie si la valeur renvoyée par une formule est #N/A. Si c’est le cas, elle renvoie la valeur VRAI sinon elle renvoie la valeur FAUX.

= ESTNA( RECHERCHEV(D3;$B$3:$B$10;1;FAUX) )

--> Résultat: FAUX

= ESTNA( RECHERCHEV(D4;$B$3:$B$10;1;FAUX) )
--> Résultat: VRAI

La fonction NON permet d’inverser le résultat d’un VRAI/FAUX. Elle trasforme le VRAI en FAUX et le FAUX en VRAI.

= NON( ESTNA( RECHERCHEV(D3;$B$3:$B$10;1;FAUX) ) )

--> Résultat: VRAI

= NON( ESTNA( RECHERCHEV(D4;$B$3:$B$10;1;FAUX) ) )
--> Résultat: FAUX

Inverser le résultat non permet d’obtenir littéralement la logique « si RECHERCHEV est vrai alors ». En cellule E3 la RECHERCHEV est fructueuse.

Fonction SI

La fonction SI effectue un test logique puis retourne un résultat différent suivant que le résultat soit VRAI ou FAUX. La syntaxe de la fonction est :

= SI( test_logique ; résultat_si_vrai ; résultat_si_faux )

Dans notre exemple, nous pouvons vérifier si le résultat retourné est VRAI et renvoyer « oui » si c’est le cas. Dans tous les autres cas, nous voulons renvoyer « non ».

= SI( NON( ESTNA( RECHERCHEV(D3;$B$3:$B$10;1;FAUX) ) ) ; "oui" ; "non" )

--> Résultat: "oui"

= SI( NON( ESTNA( RECHERCHEV(D4;$B$3:$B$10;1;FAUX) ) ) ; "oui" ; "non" )
--> Résultat: "non"

Raccourcir la formule

On peut se passer de la fonction NON en inversant les résultats saisis dans la fonction SI. On obtient la logique « si RECHERCHEV est erreur alors ». 

= SI( ESTNA( RECHERCHEV(D3;$B$3:$B$10;1;FAUX) ) ; "non" ; "oui" )

--> Résultat: "oui"

= SI( ESTNA( RECHERCHEV(D4;$B$3:$B$10;1;FAUX) ) ; "non" ; "oui" )
--> Résultat: "non"

Formules en lien

5/5 - (5 votes)

Vous avez apprécié cet article ?

Pour me soutenir, cliquez sur cette publicité. Pas besoin d’acheter, un clic suffit.

Merci. 🤩

Annonces

Modèles Excel

+

Livret 

7 méthodes pour gagner 2H par semaine sur Excel

C’est gratuit 🤩

Les formations

Formations Excel

Parce que chacun devrait avoir les moyens de faire son travail sur Excel

Découvrez des formations accessibles, rapides et directement applicables.