Somme si différent de

Fonctions utilisées :
SOMME.SI et SOMME.SI.ENS différent de

Résumé

Pour faire la somme de plusieurs valeurs avec le critère différent de on peut utiliser la fonction SOMME.SI ou la fonction SOMME.SI.ENS. Dans l’exemple ci-dessus, la formule en G3 est :

= SOMME.SI.ENS( D3:D10 ; B3:B10 ; "<>Chaise" )

Cette formule permet d’additionner les valeurs des stocks (cellules D3:D10) dont les articles (plage B3:B10) ne sont pas des chaises.

Formule Excel – Somme si différent de

= SOMME.SI.ENS( plage_somme ; plage_critère1 ; "<>valeur" ; ... )

Explications

Dans l’exemple, l’objectif est de calculer le stock total des articles qui ne sont pas des chaises. Pour élaborer cette formule, on peut se servir de la fonction SOMME.SI.ENS ou de la fonction SOMME.SI. La fonction SOMME.SI.ENS permettra d’ajouter d’autres critères tandis que la fonction SOMME.SI se limite à un seul critère.

Fonction SOMME.SI.ENS

La fonction SOMME.SI.ENS permet de cumuler des valeurs sur la base d’un ou de plusieurs critères. Sa syntaxe est la suivante :

= SOMME.SI.ENS( plage_somme ; plage_critère1 ; critères1 ; ... )

Dans notre exemple, nous voulons effectuer la somme des quantités de la plage D3:D10 si les cellules en B3:B10 sont différentes de « Chaises ». On va alors se servir de la syntaxe <>. Elle permet d’exprimer le différent de.

= SOMME.SI.ENS( D3:D10 ; B3:B10 ; "<>Chaise" )

Si la valeur « Chaise » était disponible dans une cellule (ex: A1), on pourrait faire appel directement à elle :

= SOMME.SI.ENS( D3:D10 ; B3:B10 ; "<>"&A1 )

La fonction SOMME.SI.ENS accepte l’utilisation d’autres opérateurs logiques (>, <, =, >=, <=) et des caractères génériques (*, ?).

Fonction SOMME.SI

La fonction SOMME.SI permet de cumuler des valeurs sur la base d’un seul critère. Sa syntaxe est la suivante :

= SOMME.SI( plage ; critère ; [somme_plage] )

L’ordre des arguments est légèrement différent mais la solution reste la même qu’avec la fonction SOMME.SI.ENS.

= SOMME.SI( B3:B10 ; "<>"&A1 ; D3:D10 )

La fonction SOMME.SI accepte l’utilisation d’autres opérateurs logiques (>, <, =, >=, <=) et des caractères génériques (*, ?).

Formules en lien

5/5 - (5 votes)

Vous avez apprécié cet article ?

Pour me soutenir, cliquez sur cette publicité. Pas besoin d’acheter, un clic suffit.

Merci. 🤩

Annonces

Modèles Excel

+

Livret 

7 méthodes pour gagner 2H par semaine sur Excel

C’est gratuit 🤩

Les formations

Formations Excel

Parce que chacun devrait avoir les moyens de faire son travail sur Excel

Découvrez des formations accessibles, rapides et directement applicables.