Si cellule vide alors rien

Fonctions utilisées :
Si cellule vide alors rien

Résumé

Pour vérifier si une cellule est vide et ne rien afficher si c’est le cas, il faudra utiliser la fonction SI de la façon suivante :

= SI( B3 = "" ; "" ; "cellule non vide" )
--> Vérifie si la cellule est vide ou nulle
    La cellule peut contenir une formule renvoyant une valeur nulle ("")

= SI( B3 = "=" ; "" ; "cellule non vide" )
--> Vérifie si la cellule est complètement vierge

= SI( ESTVIDE(B3) ; "" ; "cellule non vide" )
--> Idem

Dans le cas où la cellule ne serait pas vide, on affiche ici « cellule non vide ». On aurait pu également appeler la valeur d’une autre cellule ou imbriquer une autre fonction.

Formule Excel – Si cellule vide alors rien

= SI( cellule = "" ; "" ; valeur_si_non_vide )
--> Vérifie si la cellule est vide ou nulle

= SI( cellule = "=" ; "" ; valeur_si_non_vide )
--> Vérifie si la cellule est complètement vierge

= SI( ESTVIDE(cellule) ; "" ; valeur_si_non_vide )
--> Vérifie si la cellule est complètement vierge

Explications

Dans notre exemple, la colonne B contient des valeurs et des cellules vides. Si la cellule est vide, une valeur vide est affichée («  »). Dans le cas contraire on affiche « cellule non vide ».

Fonction SI

La fonction SI est une fonction Excel. Elle permet de réaliser un test d’afficher un résultat si le test se révèle VRAI ou un autre résultat si le test se révèle FAUX.

Pour définir les conditions dans le test logique de la fonction SI, il faut utiliser des opérateurs logiques. Ils permettent d’exprimer des égalités ou des inégalités que vous souhaitez vérifier.

Pour vérifier si la cellule est vide ou nulle, on peut utiliser le test logique suivant :

B3=""

Dans ce cas, le test vérifie si la cellule est vide. Par contre, la cellule peut contenir une formule renvoyant une valeur nulle («  »). Si vous voulez spécifier que la cellule doit être complètement vierge, il faut utiliser l’une des syntaxes suivantes :

B3="="
ESTVIDE(B3)

Une fois les tests logiques intégrés dans les formules on obtient :

= SI( B3 = "" ; "" ; valeur_si_non_vide )
--> Vérifie si la cellule est vide ou nulle

= SI( B3 = "=" ; "" ; valeur_si_non_vide )
--> Vérifie si la cellule est complètement vierge

= SI( ESTVIDE(B3) ; "" ; valeur_si_non_vide )
--> Idem

Formules en lien

4.8/5 - (17 votes)

Vous avez apprécié cet article ?

Pour me soutenir, cliquez sur cette publicité. Pas besoin d’acheter, un clic suffit.

Merci. 🤩

Annonces

Modèles Excel

+

Livret 

7 méthodes pour gagner 2H par semaine sur Excel

C’est gratuit 🤩

Les formations

Formations Excel

Parce que chacun devrait avoir les moyens de faire son travail sur Excel

Découvrez des formations accessibles, rapides et directement applicables.