Si cellule égale à (sensible à la casse)

Fonctions utilisées :
Si cellule égale à avec sensibilité à la casse (majuscules et minuscules)

Résumé

Pour vérifier si une cellule est égale à un texte tout en tenant compte de la casse (présence ou absence de majuscules ou minuscules), il faut utiliser fonction SI associée à la fonction EXACT. Dans l’exemple ci-dessous, si la cellule B3 est égale au mot « Chaise » en tant compte de la majuscule alors la valeur « ok » s’affichera. Dans le cas contraire on affichera une valeur nulle («  »).

= SI( EXACT( B3 ; "chaise" ) ; "ok" ; "" )

Formule Excel – Si cellule égale à (sensible à la casse)

= SI( 
   EXACT( cellule ; mot_cherché ) ; 
   valeur_si_trouvé ; 
   valeur_si_non_trouvé )

Explications

Cette formule a pour objectif d’afficher une valeur suivant si une cellule contient ou non une valeur donnée et ce, en tenant compte de la présence ou de l’absence de majuscules ou de minuscules. Pour cela, nous allons nous servir de la fonction SI et de la fonction EXACT.

Fonction Exact

La fonction EXACT permet de vérifier que deux valeurs soient identiques tout en tenant compte des majuscules et des minuscules.

= EXACT( valeur_1 ; valeur_2 )

= EXACT( "Excel" ; "EXCEL" )
--> Résultat : FAUX

= EXACT( "Excel" ; "excel" )
--> Résultat : FAUX

= EXACT( "Excel" ; "Excel" )
--> Résultat : VRAI

Fonction SI

La fonction SI permet de réaliser un test logique et d’afficher une valeur si le test se révèle VRAI et une autre valeur si le test se révèle FAUX.

= SI( test_logique ; valeur_si_vrai ; valeur_si_faux )

= SI( A1 = 1 ; "c'est bon" ; "erreur" )
--> Résultat : si A1=1 alors la fonction SI renverra "c'est bon".
    Dans le cas contraire, on aura la valeur "erreur".

En plaçant la fonction EXACT en tant que test logique de la fonction SI on peut renvoyer une valeur si la cellule contient un mot exact (avec prise en compte des majuscules et minuscules). Dans le cas contraire, on peut renvoyer une autre valeur. Dans l’exemple ci-dessous, si la cellule contient le mot “Chaise” avec une majuscule alors on affiche le mot “Chaise” dans la cellule. Dans le cas contraire, on n’affiche rien (“” symbolisant une valeur nulle).

= SI( EXACT( B3 ; "Chaise" ) ; "Chaise" ; "" )

Il est possible d’afficher en tant que résultat de la fonction SI une valeur numérique, une fonction Excel, une formule ou un texte.

= SI( ... ; valeur_si_vrai ; ... )

= SI( ... ; "ok" ; ... )
--> On affiche un texte

= SI( ... ; 12 ; ... )
--> On affiche une valeur numérique

= SI( ... ; SOMME(A1:C1) ; ... )
--> On effectue un calcul via une fonction Excel

= SI( ... ; (D4+C4)*100 ; ... )
--> On réalise un calcul

Il est aussi possible d’imbriquer des fonctions SI les unes dans les autres afin de tester plusieurs éléments et de ressortir des résultat différents.

= SI( ... ; valeur_si_vrai ; ... )

= SI( ... ; SI(...) ; ...)

Formules en lien

4.9/5 - (18 votes)

Vous avez apprécié cet article ?

Pour me soutenir, cliquez sur cette publicité. Pas besoin d’acheter, un clic suffit.

Merci. 🤩

Annonces

Modèles Excel

+

Livret 

7 méthodes pour gagner 2H par semaine sur Excel

C’est gratuit 🤩

Les formations

Formations Excel

Parce que chacun devrait avoir les moyens de faire son travail sur Excel

Découvrez des formations accessibles, rapides et directement applicables.