Si cellule égale à

Fonctions utilisées :
Si cellule égale à un texte - formule Excel

Résumé

Pour vérifier si une cellule est égale à un texte, il faut utiliser fonction SI. Dans l’exemple ci-dessous, si la cellule B3 est égale au mot « chaise » alors la valeur « ok » s’affichera. Dans le cas contraire on affichera une valeur nulle («  »).

= SI( B3="chaise" ; "ok" ; "" )

Formule Excel – Si cellule égale à

= SI( 
   cellule = mot_cherché ; 
   valeur_si_trouvé ; 
   valeur_si_non_trouvé )

Explications

Cette formule a pour objectif d’afficher une valeur suivant si une cellule contient ou non une valeur donnée. Pour cela, nous allons nous servir de la fonction SI.

Fonction SI

La fonction SI permet de réaliser un test logique et d’afficher une valeur si le test se révèle VRAI et une autre valeur si le test se révèle FAUX.

= SI( test_logique ; valeur_si_vrai ; valeur_si_faux )

= SI( A1 = 1 ; "c'est bon" ; "erreur" )
--> Résultat : si A1=1 alors la fonction SI renverra "c'est bon".
    Dans le cas contraire, on aura la valeur "erreur".

Pour réaliser un test logique, on va se servir des opérateurs logiques. Ils servent à exprimer des égalités ou des inégalités que vous souhaitez vérifier.

Le tableau ci-dessous vous donne un résumé de ces différents éléments en fonction du type de donnée dans vos cellules.

TypeSyntaxeSignification
Texte“Production”la valeur est égale à Production
“<>Production”la valeur est différente de Production
Date“>”&DATE(2022;1;1)Supérieur au 01/01/2022
“>=”&DATE(2022;1;1)Supérieur ou égal au 01/01/2022
“<”&DATE(2022;1;1)Inférieur au 01/01/2022
“<=”&DATE(2022;1;1)Inférieur ou égal au 01/01/2022
DATE(2022;1;1)Date exacte
Nombres“>”&2000Supérieur à 2000
“>=”&2000Supérieur ou égal à 2000
“<”&2000Inférieur à 2000
“<=”&2000Inférieur ou égal à 2000
2000Montant exact
Autres conditions“=”Cellule vide (pas de formule ni de valeur nulle)
“”Valeur nulle (peut être le résultat d’une formule)
“<>”Cellule non vide (inclus zéro)

Il est possible d’afficher en tant que résultat de la fonction SI une valeur numérique, une fonction Excel, une formule ou un texte.

= SI( ... ; valeur_si_vrai ; ... )

= SI( ... ; "ok" ; ... )
--> On affiche un texte

= SI( ... ; 12 ; ... )
--> On affiche une valeur numérique

= SI( ... ; SOMME(A1:C1) ; ... )
--> On effectue un calcul via une fonction Excel

= SI( ... ; (D4+C4)*100 ; ... )
--> On réalise un calcul

Il est aussi possible d’imbriquer des fonctions SI les unes dans les autres afin de tester plusieurs éléments et de ressortir des résultat différents.

= SI( ... ; valeur_si_vrai ; ... )

= SI( ... ; SI(...) ; ...)

Limitations

Cette solution permet de vérifier si une cellule est égale à un mot en particulier. Cependant, elle ne tient pas compte de la présence ou de l’absence des majuscules et minuscules. Pour cela, il faut se tourner vers la solution Si cellule égale à (sensible à la casse).

Formules en lien

4.8/5 - (17 votes)

Vous avez apprécié cet article ?

Pour me soutenir, cliquez sur cette publicité. Pas besoin d’acheter, un clic suffit.

Merci. 🤩

Annonces

Modèles Excel

+

Livret 

7 méthodes pour gagner 2H par semaine sur Excel

C’est gratuit 🤩

Les formations

Formations Excel

Parce que chacun devrait avoir les moyens de faire son travail sur Excel

Découvrez des formations accessibles, rapides et directement applicables.