Fonction ESTVIDE

La fonction ESTVIDE est une fonction Excel renvoyant VRAI si la cellule ne contient aucune valeur et FAUX si elle contient une valeur quelconque ou une valeur nulle («  »).
Utilisation de la fonction ESTVIDE sur Excel

Syntaxe

La fonction ESTVIDE s’écrit de la façon suivante :

= ESTVIDE( valeur )

Cette fonction possède un argument.

  • valeur – Valeur à vérifier.

La fonction ESTVIDE permet de vérifier si le contenu d’une cellule est vide. Un résultat nul («  ») ne sera pas considéré comme vide. Si la cellule est vide, le résultat renvoyé sera VRAI. Dans le cas contraire, le résultat renvoyé sera FAUX.

= ESTVIDE( A1 )

Il est possible d’effectuer cette opération sur une plage de cellule. La fonction renverra comme réponse une matrice de même dimension composée de VRAI et FAUX.

= ESTVIDE( E3:E14 )
La fonction ESTVIDE sur une plage de cellules

Cette fonction est vraiment intéressante pour identifier facilement et rapidement les cellules qui semblent vides mais ne le sont pas. Il s’agira des cellules avec une valeur nulle («  ») ou les cellules contenant des espaces.

Quelques utilisations de la fonction ESTVIDE

Vérifier si une cellule est vide

Pour cela, il suffit de placer les coordonnées de la cellule entre parenthèses

= ESTVIDE( A1 )

Vérifier si une cellule n’est pas vide

À l’inverse, il peut être intéressant d’inverser la logique de la formule et vérifier sur une formule n’est pas vide. Pour cela, il faudra l’imbriquer dans la fonction NON. Cette dernière transforme les valeurs VRAI en FAUX et inversement.

= NON( ESTVIDE( A1 ) )

Identifier les valeurs nulles

Comme expliqué, la fonction ESTVIDE considère les valeurs nulles («  ») comme étant des valeurs. Pour les identifier et corriger les limites de la fonction, on peut se servir de la fonction NBCAR. Associée à la fonction SI, on peut préciser le résultat que l’on souhaite faire ressortir.

= NBCAR( A1 )
--> Compte le nombre de caractères en A1

= SI( NBCAR(A1) > 0 ; "La cellule n'est pas vide" ; "cellule vide" )

Compter le nombre de cellules vides

Il est possible de compter le nombre de cellules vides en associant la fonction ESTVIDE avec la fonction SOMME et en utilisant la double négative.

= SOMME( --ESTVIDE( E3:E14 ) )

Formules en lien

Fonctions en lien

4.8/5 - (19 votes)

Vous avez apprécié cet article ?

Pour me soutenir, cliquez sur cette publicité. Pas besoin d’acheter, un clic suffit.

Merci. 🤩

Annonces

Modèles Excel

+

Livret 

7 méthodes pour gagner 2H par semaine sur Excel

C’est gratuit 🤩

Les formations

Formations Excel

Parce que chacun devrait avoir les moyens de faire son travail sur Excel

Découvrez des formations accessibles, rapides et directement applicables.