Excel en un Cleex

Fonction ESTFORMULE

La fonction ESTFORMULE est une fonction Excel qui renvoie VRAI lorsqu’une cellule contient une formule. Dans le cas contraire elle renvoie FAUX. Elle est utile pour identifier rapidement si une base de données contient des formules.
Fonction ESTFORMULE Excel - Cleex

Syntaxe

La fonction ESTFORMULE s’écrit de la façon suivante :

= ESTFORMULE( référence_cellule )

Cette fonction possède un argument.

  • référence_cellule – Coordonnées de la cellule ou des cellules sur lesquelles nous voulons vérifier si il y a une formule.

La fonction ESTFORMULE permet de vérifier si une cellule ou une plage de cellules contiennent des formules. Si c’est le cas, la valeur retournée sera VRAI. Dans le cas contraire, elle affichera FAUX.

Elle ne possède qu’un seul argument. Il s’agit des coordonnées des cellules.

= ESTFORMULE( B3 )
B3 contient '=1+1'
--> Résultat : VRAI

= ESTFORMULE( B7 )
B7 contient '121'
--> Résultat : FAUX

Par défaut, dès lors que la cellule contiendra une formule du type « =… », elle sera considérée comme contenant une formule et ce, peu importe que l’on utilise ou non une fonction Excel.

= ESTFORMULE( A1 )

A1 contient '=1'
--> Résultat : VRAI

A1 contient ' ="bureau" '
--> Résultat : VRAI

A1 contient ' = SOMME(A1:B1) '
--> Résultat : VRAI

A1 contient ' bureau '
--> Résultat : FAUX

Il est possible de compter le nombre de cellules contenant une formule utilisant la fonction SOMMEPROD associée à la double négative.

= SOMMEPROD( --ESTFORMULE( B3:B7 ) )

La double négative transforme les résultats retournés par la fonction ESTFORMULE (VRAI/FAUX) et les convertit en 1 et 0 afin de pouvoir effectuer des opérations dessus.

= SOMMEPROD( --ESTFORMULE( B3:B7 ) )

= SOMMEPROD( --({VRAI;VRAI;FAUX;FAUX;VRAI}) )

= SOMMEPROD( {1;1;0;0;1} ) 

= 3

Formules en lien

Fonctions en lien

5/5 - (1 vote)

Vous avez apprécié cet article ?

Pour me soutenir, cliquez sur cette publicité. Pas besoin d’acheter, un clic suffit.

Merci. 🤩

Annonces

Modèles Excel

+

Livret 

7 méthodes pour gagner 2H par semaine sur Excel

C’est gratuit 🤩

Formation Excel (100% finançable)

Un programme personnalisé, avec un formateur expert attitré et selon vos disponibilités.

Formations Excel

Parce que chacun devrait avoir les moyens de faire son travail sur Excel

Découvrez des formations accessibles, rapides et directement applicables.