Comment corriger l’erreur #REF!

L’erreur #REF! sur Excel se produit lorsque une formule à des références de cellules ou de plages de cellules invalides.
Corriger l'erreur #REF! sur Excel

Résumé

L’erreur #REF! est une erreur courante sur Excel. Elle est souvent issue d’une formule dans les références (cellules) ont été supprimées. Ça a pu se faire lors de la suppression de cellules, de lignes, de colonnes ou d’onglets entiers. La meilleure solution sera alors de saisir les nouvelles coordonnées.

= SOMME(#REF!) --> SOMME(C3:C7)

Solutions pour corriger l’erreur #REF!

Il est toujours frustrant de travailler de longues heures sur un document Excel et de découvrir des #REF! après le passage d’un collègue. Voici quelques conseils pour limiter ce type de cas.

Protéger votre document

La première solution est de mettre une protection sur l’onglet et le classeur pour empêcher les personnes de supprimer des lignes, des colonnes, des cellules et des onglets. Vous n’êtes pas obligé de mettre un mot de passe pour rendre effective la protection.

Utiliser la fonction INDIRECT pour rendre immuable vos coordonnées

Dans certains cas, les manipulations quotidiennes nécessitent la suppression de cellules, de lignes, de colonnes ou d’onglets. Elles seront par la suite remplacées par de nouvelles valeurs. Dans ce cas, vous pouvez rendre immuables vos coordonnées en vous servant de la fonction INDIRECT. Celle-ci permet de saisir un texte et d’indiquer à Excel qu’il s’agit de coordonnées valides.

= SOMME( INDIRECT("C3:C7") )

Corriger les #REF! en masse

Si vous avez un grand nombre de cellules qui faisaient appel aux mêmes cellules source, il peut être intéressant de les sélectionner et de faire un « rechercher et remplacer ». Vous recherchez #REF! et vous remplacez cette valeur par les coordonnées valides.

Annuler le #REF!

Si vous provoquez un #REF! après la suppression des cellules sources, le mieux est d’annuler l’opération grâce à ctrl+Z et d’adapter votre stratégie de suppression.

Formules en lien

4.8/5 - (19 votes)

Vous avez apprécié cet article ?

Pour me soutenir, cliquez sur cette publicité. Pas besoin d’acheter, un clic suffit.

Merci. 🤩

Annonces

Modèles Excel

+

Livret 

7 méthodes pour gagner 2H par semaine sur Excel

C’est gratuit 🤩

Les formations

Formations Excel

Parce que chacun devrait avoir les moyens de faire son travail sur Excel

Découvrez des formations accessibles, rapides et directement applicables.