Comment corriger l’erreur #NOM? sur Excel

L’erreur #NOM? sur Excel indique qu’il ne comprend pas une valeur saisie. Il peut s’agir du nom de la fonction, des coordonnées, de la plage nommée. Il n’y a pas de parade ou de formule pour la corriger. La solution est alors de trouver la source de l’erreur.
Corriger l'erreur #NOM? sur Excel

Résumé

L’erreur #NOM? signifie qu’Excel ne comprend pas une valeur, des coordonnées ou une plage nommée. Il faut alors trouver quelle est votre erreur.

= RECHERHCEV( ... )
--> Résultat : #NOM?
    Erreur sur le nom de la fonction.

= RECHERCHEV( Réf-0123 ; ... )
--> Résultat : #NOM?
    Oublie des guillemets. Excel cherche alors la plage nommée
    correspondante.

= RECHERCHEV( "Réf-0123" ; base_artcle ; ... )
--> Résultat : #NOM?
    La plage nommée s'appelle base_article (oubli du s)

= RECHERCHEV( AA ; base_article ; ... )
--> Résultat : #NOM?
    Les coordonnées (A1) sont mal orthographiées.

Explications

L’erreur #NOM? indique une vraie erreur de syntaxe dans votre formule. Il faut alors la corriger. Dans la majorité des cas, cela vient d’une faute d’orthographe sur le nom de la fonction. En cas de doute, rendez-vous dans la liste des fonctions Excel.

Erreur sur le nom de la fonction (#NOM?)

Dans ce cas, vérifiez bien l’orthographe de la fonction que vous souhaitez utiliser. Dans l’exemple ci-dessous il s’agit d’une faute sur la fonction RECHERCHEV.

= RECHECHEV( ... )
--> Résultat : #NOM?

Erreur sur une plage nommée (#NOM?)

En cas d’utilisation de plages nommées, si vous faites une faute sur celles-ci, Excel vous renverra l’erreur #NOM?.

= RECHERCHEV( ... ; base_artcle ; ... )
--> Résultat : #NOM?
    La plage nommée est base_articles

Erreur sur des coordonnées (#NOM?)

Si vous inscrivez les coordonnées des cellules manuellement, vous pouvez être victime d’une erreur de frappe.

= RECHERCHEV( AA ; base_article ; ... )
--> Résultat : #NOM?
    Les coordonnées (A1) sont mal orthographiées.

Texte interprété comme une plage nommée

Si vous oubliez les guillemets lors de la saisie d’un texte, Excel comprendra qu’il s’agit d’une plage nommée.

= RECHERCHEV( Réf-0123 ; ... )
--> Résultat : #NOM?
    Oublie des guillemets. Excel cherche alors la plage nommée
    correspondante.

Enlever les #NOM? avec la fonction SIERREUR

La fonction SIERREUR permet de renvoyer une valeur de remplacement si la fonction imbriquée renvoie une erreur. Pour rappel, l’erreur #NOM? requiert une correction de la syntaxe. Cependant, dans des cas rarissimes, vous pouvez vouloir neutraliser cette erreur

= SIERREUR( RECHERCHEVVVVVV(...) ; valeur_si_erreur )

Enlever les #NOM? avec la fonction SIERR

La fonction SIERR fonctionne comme la fonction SIERREUR. La seule différence est quelle ne traite pas l’erreur #N/A comme telle.

= SIERR( RECHERCHEVVVVVV(...) ; valeur_si_erreur )

Formules en lien

4.8/5 - (15 votes)

Vous avez apprécié cet article ?

Pour me soutenir, cliquez sur cette publicité. Pas besoin d’acheter, un clic suffit.

Merci. 🤩

Annonces

Modèles Excel

+

Livret 

7 méthodes pour gagner 2H par semaine sur Excel

C’est gratuit 🤩

Les formations

Formations Excel

Parce que chacun devrait avoir les moyens de faire son travail sur Excel

Découvrez des formations accessibles, rapides et directement applicables.