Compter le nombre de cellules contenant une date

Fonctions utilisées :
Excel compter le nombre de cellule contenant une date

Résumé

Pour compter le nombre de cellules contenant une date, la première solution est d’utiliser la fonction NB. Dans notre exemple, la formule en E6 est :

= NB(B5:B12)

Cette formule permet de compter le nombre de cellules dans la plage B5:B12 qui contiennent une valeur numérique (une date étant traitée comme telle par Excel).

Cette solution ne permet pas de limiter des erreurs courantes de confusion entre un nombre réel et une date. Le mieux est de borner nos dates. Les deux solutions sont présentées ci-après.

Formule Excel – Compter le nombre de cellule contenant une date

= NB( dates )

Explications

Lorsque vous saisissez dans Excel une date, vous saisissez en réalité une valeur numérique sur laquelle il vient appliquer une mise en forme particulière. Le 1 est le 01/01/1900, le 2 est le 02/01/1900,…

Pour compter des valeurs numériques, il faudra se servir de la fonction NB. Par contre, si votre plage de cellules contient des valeurs aberrantes (dates étranges, véritables nombres) vous risquez de les compter. La solution est alors de borner les dates acceptables.

Fonction NB

La fonction NB est une fonction Excel permettant de compter des cellules qui contiennent des valeurs numériques. Elle s’écrit de la façon suivante :

= NB( plage )

Dans notre cas, nous voulons compter les cellules de la colonne B qui contiennet des valeurs numériques :

= NB( B5:B12 )
--> Résultat: 6

Le résultat renvoyé est de 6. La fonction a ignoré les cellules contenant du texte.

Traiter les valeurs aberrantes

Pour limiter les erreurs, le mieux est de borner les dates. Nous allons définir une date inférieure et une date supérieure.

La fonction NB.SI.ENS est une fonction Excel permettant de compter des cellules qui remplissent un ou plusieurs critères. Pour cela nous allons utiliser les opérateurs logiques (>, <, <>, =). La fonction NB.SI.ENS s’écrit de la façon suivante :

= NB.SI.ENS( plage_critère1 ; critères1 ; ... )

Dans notre cas, nous voulons compter les cellules de la colonne B :

= NB.SI.ENS( B5:B12 ;

Si les dates présentes sont supérieures ou égales à la borne inférieure (cellule E5). Pour cela, on va utiliser l’opérateur logique >= et le concatener avec la cellule.

= NB.SI.ENS( B5:B12 ; ">=" & E5 ;

Remarquez la synthase particulière « opérateur logique »&cellule. Elle est importante.

A présent, nous voulons définir la borne supérieure. La plage de valeurs sur laquelle appliquer notre critère est de nouveau la plage des dates. Nous voulons qu’elles soient inférieures ou égales à notre borne supérieure (cellule F5).

= NB.SI.ENS( B5:B12 ; ">=" & E5 ; B5:B12 ; "<=" & F5 )

Formules en lien

4.9/5 - (8 votes)

Vous avez apprécié cet article ?

Pour me soutenir, cliquez sur cette publicité. Pas besoin d’acheter, un clic suffit.

Merci. 🤩

Annonces

Modèles Excel

+

Livret 

7 méthodes pour gagner 2H par semaine sur Excel

C’est gratuit 🤩

Les formations

Formations Excel

Parce que chacun devrait avoir les moyens de faire son travail sur Excel

Découvrez des formations accessibles, rapides et directement applicables.