Excel en un Cleex

Les caractères génériques sur Excel

Les caractères génériques dans Excel sont des caractères spéciaux (*,?,~) vous permettant d’indiquer à Excel que vous souhaiter retrouver des valeurs non exactes.
Les caractères génériques dans Excel

Les caractères génériques permettent d’indiquer à Excel que nous souhaitons retrouver des valeurs approchantes. Par exemple, si je veux compter le nombre de cellules commençant par un texte précis, je vais utiliser la formule suivante :

=NB.SI(E3:E11;"Production*")

L’astérix (*)

L’astérix dans Excel permet de remplacer plusieurs chaînes de caractères dans une formule. Par exemple, si je souhaite indiquer que je veux compter le nombre de cellules se terminant par un texte précis, je vais utiliser la formule suivante :

=NB.SI(E3:E11;"*Production")

Le point d’interrogation (?)

Le point d’interrogation indique à Excel que vous voulez remplacer un seul caractère. C’est très pratique lorsque vous voulez compter un nombre de valeurs en sachant que certaines ont un accent et d’autres non (« salariés », « salaries »). La formule s’écrira de la façon suivante :

=NB.SI(E3:E11;"salari?s")

Un autre cas d’usage très intéressant est pour pouvoir compter le nombre de cellules contenant un nombre de caractères spécifiques. Dans l’exemple ci-dessous, on compte le nombre de cellules ayant 3 caractères.

=NB.SI(E3:E11;"???")

L’accent (~)

L’accent permet de neutraliser le pouvoir des caractères spécifiques. Vous indiquez à Excel que vous voulez le caractère litéral. Par exemple, si je recherche les cellules se terminant par :

=NB.SI(E3:E11;"*~?")

Comme dans l’exemple ci-dessous, l’accent neutralise le caractère qui est placé juste derrière lui. L’astérix indique que nous voulons une chaine de caractère. Le point d’interrogation précédé de l’accent précise que nous voulons que la valeur se termine par un point d’interrogation.

Pour faire cet accent bizarre sur Windows, cliquez sur Shift et tapez sur la touche contenant l’accent ~. 

Quelques exemples d’usage

FormuleSignificationExemple
*Chaîne de caractères"abc", "a", "aaaaaa"
?Un caractère"a", "B"
???Trois caractères"aBC", "AAA"
*eurosSe terminant par euros"4 euros"
Bureau*Commençant par"Bureau d'études"
?*Au moins un caractère"A", "AAA"
salari?sUn caractère remplacé"salaries", "salariés"
?????-?????5 caractères + tirets + 5 caractèresAB123-BC456
*~?Se terminant par ?"ça va ?"
*prod*Contient "prod""Service production"

À noter que les caractères génériques ne fonctionnent pas avec des nombres à moins que ceux-ci aient été converti en format texte.

Toutes les fonctions ne permettent pas d’utiliser les caractères génériques. Seules les fonctions suivantes le permettent :

4.9/5 - (7 votes)

Vous avez apprécié cet article ?

Pour me soutenir, cliquez sur cette publicité. Pas besoin d’acheter, un clic suffit.

Merci. 🤩

Annonces

Modèles Excel

+

Livret 

7 méthodes pour gagner 2H par semaine sur Excel

C’est gratuit 🤩

Formation Excel (100% finançable)

Un programme personnalisé, avec un formateur expert attitré et selon vos disponibilités.

Formations Excel

Parce que chacun devrait avoir les moyens de faire son travail sur Excel

Découvrez des formations accessibles, rapides et directement applicables.