Excel en un Cleex

Récupérer jour de la semaine

Fonctions utilisées :
jours de la semaine excel

Résumé

Pour obtenir le jour de la semaine via une formule Excel, il faudra utiliser la fonction JOURSEM si on veut récupérer le numéro du jour. Pour récupérer le jour de la semaine en lettres, il faudra utiliser la fonction TEXTE. Dans notre exemple, la formule en D5 est :

= TEXTE( B5 ; "jjjj" )

Cette formule permet de récupérer le jour de la semaine en lettres de la date du 01/01/2024. Le résultat est « lundi ».

Formule Excel – Récupérer jour de la semaine

= TEXTE( date ; "jjjj" )

Explications

Dans notre cas, l’objectif est de récupérer le jour de la semaine en fonction des dates données. Il existe plusieurs méthodes suivant si l’on veut récupérer le jour en chiffres ou en lettres.

Récupérer le numéro du jour de la semaine

Pour récupérer le numéro de jour de la semaine et que le lundi soit égal au jour 1, il faut utiliser la fonction JOURSEM avec la valeur 2 en tant que second argument. Dans notre exemple, la formule en C5 est :

=JOURSEM( B5 ; 2 )
--> Résultat: 1

Le second argument est le type de calcul. Il est optionnel. Par défaut, ce sera la valeur 0 qui sera prise en compte et Excel considérera que le premier jour de la semaine est le dimanche (logique anglo-saxone). Pour que le premier jour de la semaine soit le lundi, il faudra indiquer 2 en tant qu’argument.

Récupérer le nom du jour de la semaine avec TEXTE

La fonction TEXTE permet de convertir des nombres et dates en textes tout en spécifiant le format attendu. Dans notre cas, nous souhaitons extraire le nom du jour de la semaine. Pour cela, il faudra indiquer le format « jjjj ». La formule en D5 est :

=TEXTE( B5 ; "jjjj" )
--> Résultat: "lundi"

Par cette opération, la date devient du texte et on perd la notion de date.

Récupérer le nom du jour de la semaine avec CHOISIR

Nous avons vu précédemment que la fonction JOURSEM permettait de ramener le numéro du jour de la semaine. La fonction CHOISIR permet de renvoyer une valeur dans une liste en fonction de sa position. Le premier argument est la position de la valeur dans la liste. Les arguments suivants sont les valeurs qui la compose. La formule en D10 est :

=CHOISIR( JOURSEM(B10;2) ; 
          "lundi"; "mardi"; "mercredi"; 
          "jeudi"; "vendredi"; "samedi"; 
          "dimanche" )
--> Résultat: "lundi"

Le premier argument sera le numéro du jour de la semaine tel que calculé par la fonction JOURSEM. On indiquera la liste des jours de la semaine pour les arguments suivants. Si JOURSEM ramène 1, la fonction CHOISIR renverra « lundi ». S’il s’agit de la valeur 3, ce sera « mercredi ».

Le seul avantage de cette solution par rapport à la fonction TEXTE est la possibilité de personnaliser les valeurs. Par exemple, nous pourrions souhaiter mettre des versions plus courtes des jours de la semaine. Voici un exemple de formule :

=CHOISIR( JOURSEM(B10;2) ; 
          "lun."; "mar."; "mer."; 
          "jeu."; "ven."; "sam."; 
          "dim." )
--> Résultat: "lun."

Formules en lien

4.9/5 - (7 votes)

Vous avez apprécié cet article ?

Pour me soutenir, cliquez sur cette publicité. Pas besoin d’acheter, un clic suffit.

Merci. 🤩

Annonces

Modèles Excel

+

Livret 

7 méthodes pour gagner 2H par semaine sur Excel

C’est gratuit 🤩

Formation Excel (100% finançable)

Un programme personnalisé, avec un formateur expert attitré et selon vos disponibilités.

Formations Excel

Parce que chacun devrait avoir les moyens de faire son travail sur Excel

Découvrez des formations accessibles, rapides et directement applicables.