RECHERCHEV et CONCATENER

Fonctions utilisées :
Utiliser RECHERCHEV et CONCATENER sur Excel

Résumé

Lorsqu’on veut utiliser la fonction RECHERCHEV et la fonction CONCATENER, c’est que l’on veut indiquer plusieurs critères à notre fonction de recherche. Même si ça n’est pas forcément la meilleure solution pour faire une RECHERCHEV avec plusieurs critères, elle peut vous permettre d’arriver à vos fins.

La formule suivante permet de cumuler la fonction RECHERCHEV avec la fonction CONCATENER.

= RECHERCHEV( CONCATENER(G2;G3) ; B2:E7 ; 4 ; FAUX )

Suite à la création d’une colonne d’aide qui regroupe les valeurs contenues dans les colonnes « articles » et « année », on effectue une RECHERCHEV dans le tableau en indiquant en valeur recherchée la concaténation des deux valeurs recherchées.

Formule Excel – RECHERCHEV et CONCATENER

= RECHERCHEV( CONCATENER(valeur_1;valeur_2) ; matrice ; col ; valeur_proche )

Explications

Lors de l’utilisation de la fonction RECHERCHEV, on peut vouloir indiquer plusieurs critères. Il y a plusieurs techniques pour cela. L’une d’entre elles est la création d’une colonne d’aide concaténant l’ensemble des colonnes de critères.

Cette colonne doit être placée à gauche du tableau car la RECHERCHEV recherche la valeur cherchée dans la première colonne de la matrice sélectionnée.

Ensuite, il suffit d’utiliser la fonction CONCATENER ou le caractère & pour concaténer nos différents critères de recherche et les placer en tant qu’argument de recherche.

= RECHERCHEV( CONCATENER( G2;G3 ) ; B2:E7 ; 4 ; FAUX )

Limites

Vous l’aurez compris, je ne vous conseille pas cette solution car elle implique la création d’une nouvelle colonne et se cantonne à des cas bien particuliers. Elle ne pourra fonctionner que pour des égalités :

= C2:C7 = "chaise"  --> Égal à "chaise"

Mais pas des inégalités :

= C2:C7 <> "chaise"  --> Différent de chaise
= D2:D7 < 2019       --> Inférieur à 2019
= D2:D7 > 2019       --> Supérieur à 2019
...

Je vous invite donc à vous tourner vers d’autres solutions comme l’utilisation de la fonction SOMMEPROD.

Formules en lien

4.8/5 - (16 votes)

Vous avez apprécié cet article ?

Pour me soutenir, cliquez sur cette publicité. Pas besoin d’acheter, un clic suffit.

Merci. 🤩

Annonces

Modèles Excel

+

Livret 

7 méthodes pour gagner 2H par semaine sur Excel

C’est gratuit 🤩

Les formations

Formations Excel

Parce que chacun devrait avoir les moyens de faire son travail sur Excel

Découvrez des formations accessibles, rapides et directement applicables.