Excel en un Cleex

Fonction ET

La fonction ET est une fonction Excel. Elle permet de cumuler plusieurs tests logiques et vérifier que tous se révèlent exacts. Le résultat de la fonction ET sera :
  • VRAI si tous les tests sont exacts
  • FAUX si au moins un test est FAUX
Fonction ET sur Excel - Exemple dans un tableau

Syntaxe

La fonction ET s’écrit de la façon suivante :

=ET( test_logique_1 ; [test_logique_2] ; ... )

Les arguments de la fonction sont exclusivement :

Le résultat de chaque argument ne peut s’exprimer que sous forme de :

  • VRAI ou FAUX
  • 1 ou 0 (1 représentant la valeur VRAI, 0 représentant la valeur FAUX)

La fonction ET va permettre de cumuler plusieurs tests logiques et de faire ressortir la valeur VRAI si tous les tests se révélent exacts. Si au moins un test renvoie la valeur FAUX, alors le résultat de la fonction ET sera FAUX.

A1=75
B1="Pierre"
C1="01/01/2024"
D1="Test"

=ET( A1>50 ; B1="Pierre" ; C1>"31/12/2023" ; ESTVIDE(D1) )

--- Résultat ---

=ET( VRAI ; VRAI ; VRAI ; FAUX )

--> Le résultat de la fonction ET sera FAUX

Comment utiliser la fonction ET dans Excel ?

Il est rare que vous utilisiez la fonction ET seule. Généralement, vous allez vous en servir avec la fonction SI pour faire une fonction SI avec plusieurs critères et pour éviter l’utilisation de SI imbriqués sur Excel. La fonction OU se révèlera également utile.

Dans l’exemple ci-dessous, on vérifie que la première valeur soit inférieure à 75 et la seconde supérieure à 75. Plutôt que d’afficher le résultat VRAI, nous nous servons de la fonction SI pour afficher le résultat « Bon » si c’est le cas. Dans le cas contraire, c’est le résultat « Mauvais » qui sera affiché.

=SI( ET( B3<75 ; C3>75 ) ; "Bon" ; "Mauvais" )

Ça sera très utile notamment pour vérifier qu’une valeur est comprise entre deux dates. Dans l’exemple ci-dessous, nous vérifions que la date dans la cellule A1 est bien une date de 2023. Pour cela nous vérifions tour-à-tour que la date est supérieure ou égale au 1er Janvier 2023 et inférieure ou égale au 31/12/2023. Si c’est le cas, nous voulons voir la valeur « Ok » s’afficher dans notre cellule. Si ce n’est pas le cas, nous voulons que rien ne s’affiche. Pour cela on utilise le symbole «  ».

=SI( ET( A1>="01/01/2023" ; A1<="31/12/2023" ) ; "Ok" ; "" )

Caractéristiques de la fonction ET

Voici quelques informations importantes sur la fonction ET :

Formules en lien

Fonctions en lien

4.8/5 - (21 votes)

Vous avez apprécié cet article ?

Pour me soutenir, cliquez sur cette publicité. Pas besoin d’acheter, un clic suffit.

Merci. 🤩

Annonces

Modèles Excel

+

Livret 

7 méthodes pour gagner 2H par semaine sur Excel

C’est gratuit 🤩

Formation Excel (100% finançable)

Un programme personnalisé, avec un formateur expert attitré et selon vos disponibilités.

Formations Excel

Parce que chacun devrait avoir les moyens de faire son travail sur Excel

Découvrez des formations accessibles, rapides et directement applicables.